Quarterly cost: 0
 
April 04, 2020, 08:42:52 AM +0100 *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
Series
S3655GP
S3666F1
S3667F1J
S3667F1S
S3669xF1
Recent
S3655GP Roy Hesketh (1…
S3666F1 Daytona (Speed…
S3667F1S Spa (1947-78)
S3667F1J Spa (1947-78)
S3669xF1 Zeltweg (1969…
Forthcoming
S3655GP Grenzlandring …
S3666F1 Brands Hatch (…
 
   Home   Help Search Calendar Login Register     LM2 Replays Rules Links Circuits Teams  
Pages: [1]
  Print  
Author Topic: Missing Posts  (Read 119 times)
0 Members and 1 Guest are viewing this topic.
Phil Thornton
UKGPL Consigliere
Administrator
Hero Member
*****
Posts: 4717


View Profile
« on: January 26, 2020, 11:12:51 PM +0000 »

Has anyone noticed posts being deleted?

I posted in the 67F1 Junior Round 1 thread but the post is missing. However if I go to my profile and click on "Show Posts" the missing post is there and I can even click on it to quote a reply like this:

Andreas
I've read your report and looked at the replay, I can confirm you were dropped from the server at some point and so one of your laps wasn't registered. I've corrected the race result.

There was no need for you to go to the trouble of reporting this as an incident, just a post on this race thread would have been sufficient to bring it to the moderator's attention. We can fix this sort of error without moderation.

Good luck for the rest of the season  Grin

I think Tim and Pepe have had similar problems (See here) has anyone else had similar issues?
Logged
Dave 'Gizmo' Gymer
Director General
SimRacing.org.uk Staff
Hero Member
****
Posts: 15016


Currum auriga quasi furtivum


View Profile WWW
« Reply #1 on: January 27, 2020, 08:44:58 AM +0000 »

How odd. The database shows that post (327722) with the correct board and topic IDs. Huh
Logged

To finish first, first you must have fins.
Dave 'Gizmo' Gymer
Director General
SimRacing.org.uk Staff
Hero Member
****
Posts: 15016


Currum auriga quasi furtivum


View Profile WWW
« Reply #2 on: January 27, 2020, 11:00:20 AM +0000 »

Well, that was confusing. When SMF reads the posts for anything but the last page of a topic, it starts from the index of the first post for that page (e.g. if there are 15 posts per page, for page 1 it starts from 0, for page 2 from 15, and so on)... but when viewing the last post of a topic, it takes the number of posts it thinks are in the topic, reverses the order, and asks for what are effectively the last n posts for the topic starting from the end. If the total count for the topic is wrong (e.g. after a hardware failure when the database replicas have to be brought in line manually), it drops posts from the last page... but always keeps the final one, thus maximising confusion. Roll Eyes

The lesson is... when there's a replication failure, after bringing the databases back in line, always tell the forum to recount all the posts in the all the topics in all the world.
Logged

To finish first, first you must have fins.
Phil Thornton
UKGPL Consigliere
Administrator
Hero Member
*****
Posts: 4717


View Profile
« Reply #3 on: January 27, 2020, 05:46:32 PM +0000 »

Thanks for looking into this Giz. A pretty obsure issue, it had me doubting my sanity! Hopefully there won't be many database issues for us to worry about but if it happens again we know what to look for.
Logged
Pages: [1]
  Print  
 
Jump to:  

Hosted by DaveGymer.com
Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.796 seconds with 29 queries.